Portaller

How to setup

There are two ways of how to use Portaller. If you want to unblock content for one device only (e.g. iPhone or SmartTV) — find that device in the left sidebar and set it up as described.

But if you want to use it on many devices inside your home network at the same time (e.g. listen to Pandora on iPhone and watch Netflix on TV) — best way is to write Portaller DNS address to the settings of your router. It will push the right DNS settings to any devices connected to it.

Which services are supported

Browser SmartTV Desktop iOS Android Apple TV
Pandora
Spotify
Netflix
Amazon Video
HBO


Windows 7

  • Click the "Network" icon in the status bar and open "Network center";
  • Select a current active connection;
  • Click "Options" in the window appeared;
  • Select "IPv4" row and choose "Options";
  • Put "107.170.15.247" as the primary DNS and "77.88.8.8" as the secondary one in the "Preferred DNS" section.



  • Mac OS X

  • Open "Network" section;
  • Select active connection and click "Advanced";
  • Open "DNS" section;
  • Click "Add" and put "107.170.15.247" as primary DNS and "77.88.8.8" as secondary.



  • PlayStation 4

    To install Netflix (Amazon, Hulu, etc.) application you need to log in to PSN using US or Canadian account.

    Application must be closed between switching regions, or it will not work.

  • Navigate to the settings menu ​and select "Network";
  • Select "Set Up Internet Connection";
  • On the next screen select "Custom​";
  • Chose your connection method — "Wi-Fi" or "LAN Cable";
  • Set "Obtain your IP address automatically";
  • DHCP host name must not be specified — select "Do Not Specify";
  • Next is your DNS settings — select "Manual";
  • Put "107.170.15.247" as the primary DNS and "77.88.8.8" as the secondary one;
  • Once you have done this press next and then test your connection.


  • XBOX One

    To install Netflix (Amazon, Hulu, etc.) application you need to log in to Xbox Live using US or Canadian account.

    Application must be closed between switching regions, or it will not work.

  • Go to the Dashboard and press the "Options" button on Xbox One controller;
  • Select "Settings" from the menu that will appear;
  • Select "Network";
  • Select "Advanced Settings";
  • Scroll to "DNS Settings" and select "Manual";
  • Put "107.170.15.247" as primary DNS and "77.88.8.8" as secondary;
  • Save changes and Xbox One will now check the internet connection.


  • Samsung SmartTV

    Changing SmartTV region

    When TV runs for the first time, it contains a few applications allowed for your country. Many presets of apps for local markets don't include Netflix, Pandora and other apps popular in USA, so if you want to use them — you need to switch SmartTV region of your TV to the United States.


    For an older model with an original remote — click on the "Smart Button" on the remote and when you see the Smart Hub — press , 2, 8, 9, .


    For new F/H series launched in 2013/2014 — enter "Settings" menu and navigate to "Support > Self Diagnosis > Reset". Make a reset (your previous information will be available) and stop the setup when you come to the Smart Hub Terms & Conditions, Privacy Policy page. Press the following sequence on your remote:



    The internet service location will appear. If you wish to view US apps (Vudu, Hulu plus etc) select "United States". Note that you cannot select 2 regions, i.e you can't have access to Netflix (US) and IVI (RU) at the same time. You must repeat the smart hub steps every time you want to change.

    When the Smart Hub has restarted it will now be set to your chosen region and download the default apps for your new region.


    Setup DNS address

  • Press "Menu" button on remote, scroll down to "Network" and chose "Network Settings";
  • Select type of your internet connection and then select "IP Settings";
  • Scroll down to DNS settings and put "107.170.15.247" as the primary DNS and the "77.88.8.8" as secondary one;
  • Your connection will test itself. Press "Next" to save the settings and exit the menu.


  • iPhone

  • Launch "Settings" and click on Wi-Fi;
  • Click on the network you are currently connected;
  • Click on the DNS field;
  • Fill the DNS separated by comma: "107.170.15.247, 77.88.8.8".



  • Android

  • Launch "Settings" and click on Wi-Fi;
  • Click and hold on the network you are currently connected to;
  • Click on the "Modify network config";
  • Set checkbox on the "Show advanced options";
  • Select "Static" in "IP settings" dropdown;
  • Fill the DNS fields by "107.170.15.247" and "77.88.8.8".



  • Apple AirPort

  • Start "AirPort Utility" and choose "Manual Setup"
  • Switch to "Internet" tab;
  • Then swith to "TCP/IP" tab;
  • Put "107.170.15.247" into "DNS Server";
  • Click "Update" to apply the new settings to the router.


  • ZTE F660

  • Login to the router control panel (it's default IP is 192.168.1.1);
  • Switch to "Network" tab;
  • Select "LAN" in the sidebar and then "DHCP Server" in the dropdown menu;
  • Put "107.170.15.247" into "DNS Server IP Address";
  • Click "Submit" to apply the new settings to the router.


  • DNSmasq

    If you use local DNS server, like DNSmasq, you can allow to enable custom DNS settings on particular domains. Add the host that you want to unlock in dnsmasq configuration file and restart service:

    $ nano /etc/dnsmasq.conf

    server=/pandora.com/107.170.15.247
    server=/tuner.pandora.com/107.170.15.247
    server=/www.spotify.com/107.170.15.247
    server=/play.spotify.com/107.170.15.247
    server=/apresolve.spotify.com/107.170.15.247
    server=/weblb-wg.gslb.spotify.com/107.170.15.247
    server=/lon3-weblb-a2.lon3.spotify.com/107.170.15.247
    server=/ip2location.com/107.170.15.247
    server=/atv-ext.amazon.com/107.170.15.247
    server=/atv-ps.amazon.com/107.170.15.247
    server=/netflix.com/107.170.15.247
    server=/uiboot.netflix.com/107.170.15.247
    server=/secure.netflix.com/107.170.15.247
    server=/api-global.netflix.com/107.170.15.247
    server=/nrdp.nccp.netflix.com/107.170.15.247
    server=/ios.nccp.netflix.com/107.170.15.247
    server=/android.nccp.netflix.com/107.170.15.247
    server=/tunein.com/107.170.15.247
    server=/radio.com/107.170.15.247
    server=/streamtheworld.com/107.170.15.247
    server=/hbogo.com/107.170.15.247
    server=/hbo.com/107.170.15.247
    server=/hbonow.com/107.170.15.247

    $ service dnsmasq restart



    Mikrotik

    If you use Mikrotik as a router, you can set it up to use Portaller DNS only for specified domains. To do this create a few rules for every domain (for Pandora as an example):

    /ip firewall layer7-protocol add name=pandora.com regexp=pandora.com

    /ip firewall mangle add action=mark-connection chain=prerouting dst-address=192.168.88.1 dst-port=53 layer7-protocol=pandora.com new-connection-mark=forwarded-dns protocol=udp

    /ip firewall nat add action=dst-nat chain=dstnat comment="portaller.com dns proxy" connection-mark=forwarded-dns to-addresses=107.170.15.247

    Where 192.168.88.1 Mikrotik IP, and 107.170.15.247 Portaller IP.



    Форма для Яндекс.Денег